View Thread: GM Remote Keyless Entry

I have an '02 Olds Alero (actually it's my wife's, I just pay for it... :)), with two keyless entry remotes. Her RKE quit yesterday, so I traded with her. I took the RKE to the dealer, and changed the battery in it, but it still doesn't work.

1 - Are these things prone to failure?

2 - In the owners manual, it says that if the RKE quits, that I can go to the dealer and get new ones, but they must be custom-coded for my vehicle. Any idea how much $$ this is going to set me back?


no clue at all, is there maybe a warranty?

Yeah, Don, it should be covered under warranty.

Originally posted by RSXDriver
Yeah, Don, it should be covered under warranty.

Duhhhhhh..... why didn't I think of that? :dizzy:

I'll have to mention that to the Missus. Maybe she'll have it done by the time I get back in August...

This being my first "RKE," I've never had it fail on me. So I don't know. :D

Be glad it's under warranty, Don - those things cost about $95. I wanted to get a spare one for my truck, but when the dealer told me how much they cost, I almost fell out. :surprised

I had RKE for my 98 GP and my current car. With the Grand Prix, the original and spare batteries lasted the entire 4.5 years, and I never had problems with them.

Yeah, warrantee should work.

The Bartender
Sounds like a failure, although the system may just need to be reprogrammed. They can lose programming, although it is not very common.

Most GM dealers have a tool that tests the transmitter to see if it's actually sending out a signal. And, yes, the transmitters aren't cheap, especially for a small circuit board with a battery and 3 or 4 button contacts.

Hey, look who made it over here! Welcome aboard Bartender!!

Actually, since I posted this, I went to the dealer and bought a battery for the RKE. I installed it, and nothing happened - still didn't operate.

So, we used the other remote that evening, and when I got home, I tried the first RKE, and everything worked fine!

Maybe they have to relearn the code after you've changed the battery, maybe the RKE has an intermittent fault, maybe it's haunted...